解决npm安装错误:No matching version found for event-stream@3.3.6

2020-06-17370次阅读gulp

从错误信息:No matching version found for event-stream@3.3.6可以知道,是由于没有找到这个包的3.3.6版本。

首先去 https://www.npmjs.com/ 网站搜索这个包,看看是否发布了这个版本:

解决方法

1、项目目录下package-lock.json文件里面去搜索查找event-stream@3.3.6,找出哪个包依赖event-stream@3.3.6。我这里是gulp-connect包依赖event-stream@3.3.6


2、在package.json里删除gulp-connect


3、npm i安装


4、再安装npm i gulp-connect --save-dev

上一篇: Type 'Timeout' is not assignable to type 'number'  下一篇: gulp打包ReferenceError: internalBinding is not defined错误  

解决npm安装错误:No matching version found for event-stream@3.3.6相关文章