React16的JavaScript环境要求

2019-05-09237次阅读React

React 16 依赖集合类型 Map 和 Set 。如果你要支持无法原生提供这些能力(例如 IE < 11)或实现不规范(例如 IE 11)的旧浏览器与设备,考虑在你的应用库中包含一个全局的 polyfill ,例如 core-js 或 babel-polyfill 。

React 16 使用 core-js 支持老版本浏览器,其 polyfill 环境可能如下:

import 'core-js/es6/map';
import 'core-js/es6/set';

import React from 'react';
import ReactDOM from 'react-dom';

ReactDOM.render(
  <h1>Hello, world!</h1>,
  document.getElementById('root')
);

React 同时还依赖于 requestAnimationFrame(甚至包括测试环境)。 你可以使用 raf 的 package 增添 requestAnimationFrame 的 shim

import 'raf/polyfill';
上一篇: meta标签开启360极速模式  下一篇: Webpack4模式(mode)及production内置优化  

React16的JavaScript环境要求相关文章